3

After having selected Arabic as an alternate language from site setting, I have updated user profile for the preferred language. The result is that all content is converted into arabic language, but the Custom Site Columns and Content Types are still displaying in english.

Can anybody suggest how to translate the Custom Site Columns and Content Types?

1

I work for a company whose product does that automatically, but doing it manually on SharePoint Online is the same as doing it on premise. You said that Arabic has been selected as an alternate language, I am presuming the site was created in English, that you are not using a content type hub, and that the Columns and Content Types were created in English.

  1. Change your language to Arabic (more on this below). In all other steps the interface will be in Arabic
  2. While in classic mode, not modern, click on Site Settings in the Settings menu, then Site Columns or Content Types
  3. For each one you want to localize, if the source column is a hyperlink then follow it. That means it is inherited from a higher level site
  4. Click on the column or content type you want to localize. Then if the name appears in English, change the name to its Arabic equivalent and save. Don't worry, the name change will only apply when your language is Arabic, the English name stays the same.

Changing your language using the user profile can take a few minutes to work and it doesn't always apply to all screens. Instead, you can remove all languages from your profile then wait for a few minutes, and then change the first language in your browser settings. That language change will be instantaneous as long as there are no languages in your user profile.

  • Your solution helped me. – Farhan Jan 4 '18 at 7:50
  • I am facing one issue in the translated Arabic Site. The link behind the document upload button in the document library contains Arabic name for the document library. When I click it, it generates 404 error Not found. – Farhan Jan 7 '18 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.