I am having some problems with search. I had stopped it because I had to perform an update. After the update it did not want to start again. So, I tried to start the search service using powershell:

Get-SPEnterpriseSearchServiceInstance -Local | Stop-SPEnterpriseSearchServiceInstance

Now status is stuck on "Unprovisioning".

TypeName    : SharePoint Server Search
Description : Index content and serve search queries
Id          : eb9f4c5d-b9d4-4cdb-a92f-2e4d8d0eda1a
Server      : SPServer Name=ABC02
Service     : SearchService Name=OSearch15
Role        : None
Status      : Unprovisioning

I added search service account in the local administrators group. I have restarted SharePoint Administration, SP Search, SP Timer, SP Search Host controller services.

Nothing so far.

Anything else I should do now to stop it and fix this issue?

1 Answer 1


I suggest you re-provisioning the Search Service Application using PowerShell command:

  1. Find the service which need to be provisioned.

Get-SPServiceInstance -All

  1. Then run the commands to provision:

    $service = Get-SPServiceInstance -Identity [paste in the GUID for the service]



    iisreset /noforce

  • sorry had tried it before, tried it again now. Did not work. Still saying paused for: external request Commented Jan 1, 2018 at 19:29
  • I am not sure if you suggestion solved the issue, but it is working at this moment. I restarted Search via UI and it worked. I am accepting your answer anyway. Commented Jan 2, 2018 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.