I have a MOSS 2007 site with a list which has several Choice columns. Two of the choice columns will not display the choices (Additional Column Settings...Type each choice on a separate line) so I cannot edit them.

Other choice columns in the list display as expected and allow changes. The Choice column is set as a Drop-Down Menu, IS Required, does not allow Fill-in's and has one of the choices set as a default.

I am the Farm Admin and Site Collection Admin, as well as a member of the site "owners" group where the list resides.

I modified one of the Choice columns a few month ago, adding a choice option, and then added a SPD workflow which uses the selected choice to determine actions in the workflow. This workflow does not change the choice column.

I now need to update the choices and add another branch to the workflow, but cannot seem to find a way to edit the column options.

Going into edit the choice column displays the Column name (which I could edit) and the Description along with the OK and Cancel buttons. The other options and the Delete button are missing.

The list has <400 items, so I was able to "save as template" including content. I then created a new list using this template and have the same problem on the new copy. I also tried "Removing" the workflow from the list copy to see if it had any affect but it does not.

I added a new choice field, and tested editing it, which works fine...however the new field won't display when I edit an existing item in the list NOR will it display when creating a new item in the list.

Anyone know what might cause this behavior?

2 Answers 2


This might not be ideal, but if you have Sharepoint Manager 2007 (Free), you could check to see if the field is set to hidden or sealed and even change this. This should at least allow you to edit the field I believe.

  • Good idea, I tried that tool from codeplex. The field was not hidden but the property "Sealed" was set to True. I changed it to False and was able to edit the choice selections. There was another choice column behaving the same way, but it won't let me change the Sealed property. I also noticed that the Content Type "Service Request" was hidden and was able to change that property, however it still does not show in my Site Content Type Gallery. Definite progress anyway. I may recreate from scratch first chance I get, but this resolves the primary issue. Thanks spevilgenius.
    – Anonymous
    Apr 20, 2010 at 17:38

Do you have management of Content Types on for the list? If so, the columns may only be editable by going to the underlying Content Type.

  • No Content Types are enabled on the list. I tested enabling and disabling them on the copy list, same behavior regardless so I disabled Content Types. Very Bizarre.
    – Anonymous
    Apr 13, 2010 at 22:21
  • The original list was initially generated using the "fab 40" help desk application template. Content Types may have been managed with that, but I changed it when I started modifying. I will look at that more.
    – Anonymous
    Apr 13, 2010 at 22:24
  • Ok, that could be it, because the Fab 40 are installed via features. Might the column be installed as a Site column? Apr 13, 2010 at 22:28
  • Created a subsite Help Desk in a safe area using the application template. the list does not have Content Types managed...and the choice field is not change-able. Turned on Content Types and it defaults to a Service Request Content type. Tried going to the new site column, still cannot change the column. Looking at that content type, it displays that it is in the group _Hidden.
    – Anonymous
    Apr 13, 2010 at 22:51
  • Yeah, messing with the Fab 40 is always an adventure. They aren't very consistent, nor are they well-documented. I'm guessing the there's a way around this with enough fiddling, but short of setting something up myself, I'm not sure what the answer is. Apr 13, 2010 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.