0

I have created a WCF RESTful service in SharePoint 2010 and it's working as expected for all the POST methods in Postman, whereas the same run from Fiddler generates authentication error.

I have searched on a couple of forums for the solution and one of the solutions was to go with Form Digest value via the following POST call :

<>/_api/contextinfo with header values as

ACCEPT: application/json;odata=verbose Content-Type: application/json;odata=verbose Host: sitename Content-Length: 196

Ths issue here is this call itself is rendering a 404 not found exception. Unable to find an appropriate solution to the actual issue.

Please help me out !!

0

Try to enable Anonymous Authentication in IIS, see if it works.

Ensure the HTTP Activation feature of .NET Framework is activated.

In addition, provide more information about your operations. If it is convenient, provide your configuration for further research.

0

SPSecurity.RunWithElevatedPrivileges(delegate(){}) serves the purpose. I think there were certain privilege issues because of which it was not rendering in the Mobile App integration as well as for fiddler too.

Finally got the answer and it's up and functional now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.