3

This is on SP 2013 and using 2013 workflow.

I have a survey list, and when a user completes the survey, we want to create a list item in another list and populate one of the fields with data from the survey.

However, I can't seem to get the workflow to start. Initially the workflow was set to start automatically upon new item creation, then wait until the Completed field equals Yes, then create the item in the other list.

I added a bunch of logging to track the workflow's progress, but I don't see anything in the Workflow History list. I then changed the workflow to be able to be manually started. After that, if I went to a survey response and looked at the workflows for that item, I could see my workflow and try to start it, but if I look at the workflow status it just sits there with internal status of "Not Started".

What's going on here, why won't my workflow start?

0

If you set item level permissions such as user can only see their own survey, the workflow won't run.

  • Ok, I relaxed the permissions and set "Show user name in survey results" to Yes, read access to "Read all responses" and create/edit access to "Create and edit all responses", but the workflow is still not starting either automatically or manually. – Dylan Cristy Dec 18 '17 at 18:24
  • any restrictions on what permissions required to start the workflow? – Vamsi K K Dec 18 '17 at 18:37
  • Not that I am aware of. Where would I even look for that? – Dylan Cristy Dec 18 '17 at 19:18
  • A checkbox, 'Require Manage List permissions' in workflow start options. Also, the workflows won't run sometimes if the user is system account. Hope you tried with other user accounts too. Also, have you created a new test survey list to see if the workflow working on it as expected? webucator.com/tutorial/advanced-microsoft-sharepoint/… – Vamsi K K Dec 18 '17 at 20:34
  • That option is not available/visible under "Allow this workflow to be manually started" in my workflow settings in Designer. I'm assuming that means that it is not set to require manage list permissions... – Dylan Cristy Dec 18 '17 at 21:30
0

I had a similar issue with sending emails. Perhaps this will also work for you.

Keep in mind I'm Site Admin so while I'm fairly positive this should also work for owners I've not tested it. This is also in the SharePoint 2013 environment with a SharePoint 2010 workflow.

I've discovered two things. One if you have a survey with no branches the workflow acts as expected. Two if you have a branching survey the workflow doesn't work unless you make it as "Start workflow automatically when an item is changed". I believe that with branching every time you go to another "page" the item is saved but not competed so the workflow isn't kicked off.

The downside to using the "item is changed" is that if a person goes back to change an answer you'll get spammed with an email for each question in the survey.

I'm still investigating this. I'll come back if I find a work around.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.