1

If I search a document in SharePoint Search, I am getting two files with different names, but the link/path to the documents are the same. Kindly help to solve this confusion.

If I search documents in Library, I get only two documents.

Here is the screen shot of documents sharing same link

0

I would start by switching to the OOB Display Template rather than the custom one to rule out an error with your custom Display Template.

  • please will you be more detailed . – Chetan Dec 19 '17 at 13:27
  • What do you need to know? Just change the Result Type Rule back to the default or remove it to determine if it is your custom Display Template that is causing the issue. – Matthew McDermott Dec 20 '17 at 13:18
  • Actually i am not using any custom type result type. – Chetan Dec 20 '17 at 13:48
  • I disagree. The Download link in your image is not out of the box. There is some customization on that page. – Matthew McDermott Dec 21 '17 at 12:39
  • The thing is it is happening from past few days . The the files that are deleted are also coming under search . In my case the above two files are deleted but still coming under search . – Chetan Dec 21 '17 at 14:52
0

This looks like a Document ID issue. Sometimes SharePoint issues a non-unique Doc ID. It helps if you state SharePoint Version as well.

This is a solution you can already find on this Forum:

  1. Open the item in whichever MS Office application (this fix might not work or even matter for non-Office documents)
  2. Go to the File tab in the Ribbon (assuming MS Office 2010 or higher), select the "Info" section, then select "Advanced Properties" from the Properties dropdown under the document thumbnail on the right side.
  3. In the properties list in the dialog that opens up, select each entry starting with _dlc and DELETE it. Close the dialog
  4. CHECK IN the document, and leave a comment for future users about what you did.
  5. Verify the document ID is different in the "View Properties" window in SharePoint
  6. Update any links based on Document ID that were pointing to this document
  • My application is on SharePoint 2013 . MicrosoftSharePointTeamServices:15.0.0.4569 – Chetan Dec 19 '17 at 9:08
  • I understood your clarification . After deleting the _dlc element in the dialogue - i should upload the same document again? – Chetan Dec 19 '17 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.