0

I have a site in which i have implemented master page and page layout using the custom css and js. I had given the relative URLs to reference the files in the Master Page.

After that, I enabled the public CDN to deploy the assets of SPFx web parts. The issue is that when I visit the site where I implemented the custom master page, now the css and js files are pointing to the public cdn urls and site stopped working.

How do I resolve the issue?

1 Answer 1

1

By default, the master pages gallery is added as a CDN endpoint when public CDN is enabled.

You could use the Remove-SPOTenantCdnOrigin PowerShell command to remove the CDN.

But the change will be applied to all site collections. It is a tenant setting. There is a similar post:

https://techcommunity.microsoft.com/t5/SharePoint-Developer/How-to-disable-public-CDN-for-particular-site-collection/m-p/138022

Remove-SPOTenantCdnOrigin.

https://docs.microsoft.com/en-us/powershell/module/sharepoint-online/remove-spotenantcdnorigin?view=sharepoint-ps

More references:

General availability of Office 365 CDN.

https://dev.office.com/blogs/general-availability-of-office-365-cdn

Office 365 Public CDN Developer Preview Release.

https://dev.office.com/blogs/office-365-public-cdn-developer-preview-release

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.