0

I am getting an error while opening the Graphical summary for a survey in SharePoint 2013:

Error=The specified view is invalid

Below is the ULS log:

Application error when access /sites/subsite/Lists/surveyList/summary.aspx, Error=The specified view is invalid. at Microsoft.SharePoint.SPViewCollection.get_Item(Guid guid) at Microsoft.SharePoint.WebPartPages.ListViewWebPart.EnsureListAndView(Boolean requireFullBlownViewSchema) at Microsoft.SharePoint.WebPartPages.ListViewWebPart.Microsoft.SharePoint.WebControls.IWebPartPageComponentProvider.get_WebPartContextualInfo() at Microsoft.SharePoint.WebPartPages.SPWebPartManager.RegisterRibbonTabs() at Microsoft.SharePoint.WebPartPages.SPWebPartManager.OnPreRender(EventArgs e) at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Any help is appreciated.

1

I fixed the page by opening the overview.aspx page in designer. There I saw link to another survey list. I think that this list was created from the template of that survey list. So I removed the old link and it worked!!

I removed the link from the <DetailLink></DetailLink> tag inside the <WebPart> tag. Please refer to below screenshot:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.