1

SharePoint 2010 (SP2) Web Part error:

One of the properties of the Web Part has an incorrect format. Microsoft SharePoint Foundation cannot deserialize the Web Part

We've recently started receiving the above Web part errors with a completely unchanged farm. The webparts are not custom and only appears to be ContentEditorWebPart and PageViewerWebPart.

A recent storage issue on one of our two WFE servers (Server 2008 R2) may be the culprit (it is currently the only operational WFE on our load-balancer whilst our other one is being worked on), but since clearing out plenty of space (log files) the problem has only arisen up to a couple of days after the event.

Having read a number of online resources there appears to be a couple of potential solutions (given our symptoms):

  • Permissions
  • Restart problem WFE

Given that the farm configuration is unchanged and we've confirmed the permissions (compared to the online resources) are correct, we're looking to restart the WFE.

The question:

Is there a way to perform a minimal restart that will have minimal impact on the service?

I.e. Is this a suitable "order" of least impact?

  • Application Pool Recycle - this appears to be the "safest" solution as it'll, essentially, keep the service up and spawn a new w3wp.exe to handle new requests.
  • IISRESET - Stop, and then start, all associated services. A heftier approach by, essentially, refreshing everything IIS related.
  • Restart WFE host.

Most importantly, will the "least impact" solution (Application Pool Recycle) identify that it now has plenty of disk space and help resolve the web parts issue???

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.