0

One of the users is getting the following error:

enter image description here

I have tried the instructions from this blog, but did not help.

I used this powershell lines:

PS C:\Windows\system32> Get-SPWOPIZone
internal-https
PS C:\Windows\system32> Update-SPWOPIProofKey
PS C:\Windows\system32> Update-SPWOPIProofKey

I restarted the timer job for "WOPI Discovery Synchronization"

I see this error as well: enter image description here

Any help?

Edit:

While searching the OWA logs I found this entry:

(WOPICheckFile,WACSERVER) Host reports UPA out of sync [status:Unauthorized, url:http://srv/sites/abc/_vti_bin/wopi.ashx/files/028e1d3949534422bc49ae788f25e74b?access_token=REDACTED_1050&access_token_ttl=1513212951778]

User profile sychnronization seems to run just fine.

Edit 2

I have disabled customError, in innetpub folder and in Layouts folder, but I still don't see a detailed error. It still shows the same error as in the print screen. I am not sure which web.config handles this.

In the ULS logs I don't see anything suspicious. I was filtering the logs with the WOPI keyword. Any keywords that I should look for?

Edit 3 I see this entry in the ULS logs:

WOPI ProcessRequest - WopiAuthenticationFailureException in WOPI.ashx  [e: Microsoft.SharePoint.SoapServer.WopiAuthenticationFailureException: UnauthorizedAccessException thrown in ObjectsFromWopiContext ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

BY the way, user has Contribute access in the site and library. I have given the user even full access and the error still occurs.

  • What error on SharePoint server event logs and uls logs? Did you try to disable the custom error from web application web.config....share the error details – Waqas Sarwar MVP Dec 13 '17 at 15:20
0

I solved it finnaly!! It was an issue with synch as the message in the log states. So after running the code below and did an IISReset just after working hours, worked just fine.

$user = Get-SPUser -web http://website.url -Identity DomainA\UserA

Move-SPUser -IgnoreSID -Identity $user -NewAlias 'DomainB\UserA'

Probably running the Update-SPWOPIProofKey may have helped as well in the process and all it needed an IISReset in the end. So I might not be 100% sure on that. Anyway, for those who will encounter the same problem, just run every thing I have mentioned above and it will be OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.