0

I am working in SP 2010, I want to run few timer jobs, but no timer jobs are running on the server, not even the inbuilt timer jobs.

The Running and Scheduled timer job sections are empty. The last timer job that ran was 20 days back, after that no timer job ran.

  • Could you try to restart SharePoint Timer Service and make sure it's started properly with the SharePoint Farm account! – Mohamed El-Qassas MVP Dec 13 '17 at 9:03
  • Thanks for your reply! However, I have already tried restarting SharePoint Timer Service with the farm account. – Rajiv Dec 13 '17 at 9:24
0

can you please try to related service in server. open run prompt type "services.msc"

here you can check you timer service is running or stop please restart it. or another option is power shell command

$svc = Get-SPEnterpriseSearchService $svc.JobDefinitions $webapp = Get-SPWebApplication | Select-Object -First 1 $webapp.JobDefinitions

Get-SPTimerJob | Format-Table Name, Service, WebApplication

Once all relevant job definitions for this server have been identified, the final step in initializing the Timer Service is scheduling them all to be run (or attempted for run) at their next designated interval. You won't see the scheduling log entries in the ULS unless you turn up logging for the Timer category to Verbose. If you do, after the previous entries you'll find an entry for every identified job definition informing you of when it is next scheduled to be run.

0

Following are some of the workarounds you can try

  1. Make sure the account running the SharePoint Timer service is the account which has the administrator Full Control permission over the site and the full permission over the content database.

  2. Restart the following Windows Services in the order shown:

    Windows SharePoint Services Timer service.

    Windows SharePoint Services Administration service.

0

I would check following.

  1. Make sure permission on Sql servers are in place...i.efarm account and app pool account.
  2. Check the event log if there are any error.
  3. You need to enable verbose logging and try to re run timer job and examine logs.
  4. Make timer jobs are not disabled.run below PowerShell to check it.

    $farm = Get-SPFarm $FarmTimers = $farm.TimerService.Instances foreach ($FT in $FarmTimers) { write-host "Server: " $FT.Server.Name.ToString(); write-host "Status: " $FT.status; write-host "Allow Service Jobs: " $FT.AllowServiceJobs; write-host "Allow Content DB Jobs: " $FT.AllowContentDatabaseJobs;"`n" }

Check this blog for troubleshooting steps.

https://blogs.technet.microsoft.com/sujesh/2017/10/16/sharepoint-timer-jobs-not-runningspecially-one-time-timer-jobs/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.