0

I have a list in which I created some columns, they all would appear in NewForm, EditForm etc... Then I went to List Settings > Advanced Settings > Checked the "Allow management of content types". Then List Settings > Under "Content Types" clicked on "Item" and changed Column Ordering. Then I switched off the "Allow management of content types" and created custom forms to replace NewForm & EditForm using SharePoint Designer...

Now when I create a new column in list it is not part of the default content type "Item". Neither do I get the option "Add to all content types" when creating new column NOR do I see "Add from existing site or list columns" in List Settings > By clicking "Item" under head Content Types. currentDay is new column which i'm unable to include in item content type

To my surprise the option of ordering column is also gone in the content type. Did custom forms mess up the content type... Can it be restored?

Snaps for reference. Kindly help!

List Settings Snapshot List Settings Snapshot

Item content type Snapshot Item content type Snapshot

1

Item content type on your list is in read only mode becouse of that you are not getting any options so first you need to make it non readable from Content Type->Advanced Settings-> Read Only to No. Then it will work.

0

When we add a new field to the custom list that contains the custom List form so custom List form does not get updated automatically when a new field is created in the underlying list (data source).

As a quick workaround, you can create a new custom form and set it as default.

Or, create a new custom form and copy the related with the new fields into the problematic form.

A similar thread for your reference:
https://social.msdn.microsoft.com/Forums/office/en-US/34818fae-a534-4d5d-9917-85683e53508d/add-field-to-existing-custom-form?forum=sharepointcustomization

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.