I've just setup SharePoint on a dedicated server and I am now going through setting up the backup plans before we start really using it.

Because SharePoint does not have an "automated" backup solution, I have had to use Scheduled tasks and the PowerShell cmdlet Backup-SPFarm.

When running this manually, it appears to work perfectly fine, but when running it via a Scheduled task that is setup to run under the Administrator, it fails with a number of errors similar to that below.

[11/11/2011 01:04:52] FatalError: Object SharePoint_Config_63c9c78d-7c3d-4b6f-bad3-8f5c448e787d failed in event OnBackup. For more information, see the spbackup.log or sprestore.log file located in the backup directory.
SqlException: Cannot perform a differential backup for database "SharePoint_Config_63c9c78d-7c3d-4b6f-bad3-8f5c448e787d", because a current database backup does not exist. Perform a full database backup by reissuing BACKUP DATABASE, omitting the WITH DIFFERENTIAL option.
BACKUP DATABASE is terminating abnormally.

It seems pretty obvious that it's telling me to perform a "full" backup first, but the problem is, I already have and it appears within the backup history within SharePoint central administration.

I am using two variations of the PowerShell script below, one for Full and one for Differential. As standard, I am performing a full backup on Sunday and then a differential backup on each of the other days.


$BackupDir = 'c:\Backup\Sharepoint'
$FromAccount = '[email protected]'
$ToAccount = '[email protected]'
$smtpServer = 'smtp.gmail.com'

$snapin = (Get-PSSnapin -name Microsoft.SharePoint.PowerShell -EA SilentlyContinue)
IF ($snapin -ne $null)
    write-host -f Green "SharePoint Snap-in is loaded... No Action taken"
    write-host -f Yellow "SharePoint Snap-in not found... Loading now"
    Add-PSSnapin Microsoft.SharePoint.PowerShell
    write-host -f Green "SharePoint Snap-in is now loaded"

Write-Host -f green "Staring Backup process"
Backup-SPFarm -Directory $BackupDir -BackupMethod Differential -BackupThreads 10 -Force -ErrorAction SilentlyContinue
Write-Host -f green "Exit: Backup process"
IF($Error[0] -ne $null)
    $xmldata = [xml](Get-Content ($BackupDir +'\spbrtoc.xml'))
    $Node = $xmldata.SPBackupRestoreHistory.SPHistoryObject | Where-Object {$_.SPErrorCount -gt '0' -and $_.SPStartTime -gt (Get-Date -DisplayHint Date)} 
    $FailureMsg =  $Node[0] | % {$_.SPFailure}
    $Att = ($Node[0] | % {$_.SPBackupDirectory}) + 'spbackup.log'
    $msgBody = 'An Error occurred while trying to backup your SharePoint Farm. Details : ' + $Failuremsg + 'Attached is the Error Log for additional reference.'

    $SMTPClient = New-Object Net.Mail.SmtpClient($smtpServer, 587) 
    $SMTPClient.EnableSsl = $true 
    $SMTPClient.Credentials = New-Object System.Net.NetworkCredential("[email protected]", "password"); 
    $SMTPClient.Send($FromAccount, $ToAccount, 'Error Occured in SharePoint Backup', $msgBody)
Write-Host -f Green "Operation Complete"

Can anyone see what I am doing wrong?



It appears that after a full backup was performed on Sunday morning, and a differential successfully on Monday morning, but this morning, it failed with the same error. Hope this helps?


  • This question may be off-topic for StackOverflow, but would be very welcome on the SharePoint.StackExchange.com site.
    – SPDoctor
    Nov 11, 2011 at 12:32
  • 1
    Just let me remove the annoying redundant tags from the title before migration...
    – Will
    Nov 11, 2011 at 13:10
  • What does your full backup script look like? My assumption it is more or less the same as your differential but with the -BackupMethod full instead. Assuming the full backup has run previously, check the logs to see if the configuration database was backed up (maybe there was an error), as the error suggests it has not.
    – shufler
    Nov 14, 2011 at 20:58
  • @shufler: Correct, my full script is exactly the same, but obviously changing the backup method to Full instead of Differential. When running via the powershell, it works fine but I get an error when it's done via the task scheduler, which is running on the same user. What is strange, is a full backup was performed on Sunday morning and a differential Monday morning fine, but this mornings differential again complains about the lack of a full backup. Odd...
    – Gavin
    Nov 15, 2011 at 12:04
  • Gavin, I noticed the first error you pasted is a SQL Exception on the configuration DB, but in your edit the failure message is "Object Search_Service_Applic..." -- are there different errors happening with the backups?
    – shufler
    Nov 16, 2011 at 0:14

2 Answers 2


This may be unrelated, but check that the privilege are set to access the files. Maybe the farm account can't access the full backup file.



I ran into a similar scenario to the one provided in the question above. For me, I run the incremental backup on a nightly basis, and only recently did I start to run into the same issue. In the end, I used the SharePoint Central Admin tool to perform an Incremental backup, where I receive the same error I did in my nightly automated job. I performed a FULL backup using Central Admin, and after I saw that worked, I then attempted an Incremental backup again (also in Central Admin), and it worked.

From there, I confirmed that my automated backup solution was now working again, so in the end, running the full backup from within Central Admin seems to have resolved the issue for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.