0

We have a sharepoint farm on-premises 2013 and we have defined 2 alternative access mapping urls for our web application, as follow:-

http://www.OurIntranet.intra Zone =  Internet 

https://www.OurIntranet.intra  Zone = Custom 

and users were able to access these 2 urls without any problem. but our customer have asked us to change the above 2 url from www.OurIntranet.intra to be www.MainIntranet.intranet. so our system admins made the changes to the DNS. then i went to the Central Administration >> Configure alternate access mappings, and i chnage the above 2 zones to match the new url. Aafter that i tried to access the new URL http://www.OurIntranet.intra and https://www.ourintranet.intra, but i was prompted to enter the username and password for 3 times, then a blank white page was displayed.. so not sure what is going on ? now since i was prompted to enter the username/password so the request have reached sharepoint in a way or another. but not sure why it keeps asking me for the username/password for 3 times then i got a white page... without showing any error. so can anyone advice how we can fix this? Thanks

  • 1
    Are you getting login prompted on the server? – Mike Dec 11 '17 at 14:43
  • @Mike can you advice more on this please? what do u exactly mean? now i tried accessing the sites from the sharepoint server itself and yea i got the prompted ..but this is the case even when i was accessing the old url, but of course after typing the username i will login to the sites.. – john Gu Dec 11 '17 at 14:55
  • 1
    Are you getting the login prompt when you are logged onto the server? If so, that's the loopback check that you'll need to disable or add to the backconnectionhostnames. See here: support.microsoft.com/en-us/help/896861/… Also, check the IIS bindings and flush your DNS cache. – Mike Dec 11 '17 at 14:58
  • @Mike maybe this is a different issue.. as even on the old url which were working well http://www.OurIntranet.intra ,, i will be prompted for username/password first, then i can access the sites correctly.. but on the new url i will be prompted to enter the username for 3 times then i will get a blank white page.. so being prompted for username/password is not the real problem ... – john Gu Dec 11 '17 at 15:02
  • That also may happen if you are using Kerberos and you don't have the correct SPN entered for the hostname, or a duplicate SPN issue. Also check the IIS bindings to make sure they are correct. – Mike Dec 11 '17 at 15:03
0

I have seen this issue before in SharePoint 2013. If you check the ULS logs you are likely to find some entries complaining about claims. In SharePoint 2013 in order to access a site the site needs to be listed in alternate access mapping. It sounds from your description like you changed the old URLs to the new ones. I would suggest adding the old ones back in, in addition to the new ones. In my experience this should solve your problem.

https://blogs.msdn.microsoft.com/sharepoint_strategery/2013/05/27/alternate-access-mappings-aams-explained/

  • now when i do so , and i try to access the new URL i will be redirected to the old url so if i type the new url https://www.mainintranet.intra i will be redirected to https://www.OurIntranet.intra... now i check the alternative access mapping again, and i can see that since i have 2 custom zones and 2 Internet zones.. so the new url https://www.mainintranet.intra is having the https://www.OurIntranet.intra as its Public URL for Zone inside the Central Administration >> Configure alternate access mappings – john Gu Dec 11 '17 at 15:14
  • You just have to set the internal and the extranet urls – Ryan Schouten Dec 12 '17 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.