We have SharePoint 2010 intranet. Some users are not able to login into SharePoint. Browser keeps on asking for credentials.

Checked for the users in Site Permissions (using admin account). The users are shown in users list and have permission.

Search the net but not getting exact cause and solution.

Kindly suggest

  • 2
    Are you sure that everything is published? (all css, js files, any documents in lists displayed in home page, etc) – dinos.kon Dec 6 '17 at 8:48
  • Yes Dinos all stuff is published. Most users are able to access intranet as expected. – shoab Dec 19 '17 at 8:22
  • Since you have already tried to add site to intranet level with automatic logon, next thing I would try is reset the IE settings. (Internet options > Advanced tab > Reset button at the bottom) (Are you having the same issues with other browsers?) – dinos.kon Dec 19 '17 at 13:23
  • Also, I have seen cases where although the user has access to a particular page, since they do not have access to the content that a WebPart displays, they receive the Access Denied page. – dinos.kon Dec 19 '17 at 13:29
  • Have the same problem. Did you fix it? – Emaborsa Jun 30 at 5:46

Do you users get any kind of error message when you click away the credential prompt? We had a similar situation and our users used to get a "401" error when clicking cancel on the credential window.

To fix our issue we added our intranet's address to the "Local Intranet" sites in IE:

enter image description here

| improve this answer | |
  • Did these settings for the user. However system intranet for login 3 times and then shows blank page. Doing a refresh again starts asking for Creds – shoab Dec 19 '17 at 8:22

I strongly suggest trying out @AM2FTW solution first.

In our case, we had some PCs which were still asking for the credentials (I think the PC settings were not managed by the Sys Admin for strange reasons), but we got rid of it by changing the User Authentication Settings in the IE Options. (Option in the screenshot below is grayed out because it was on my PC, which is fine)

IE User Authentication Settings

| improve this answer | |
  • 1
    Did these settings for the user. However system intranet for login 3 times and then shows blank page. Doing a refresh again starts asking for Creds – shoab Dec 19 '17 at 8:21
  • Is it like a white blank page with no error code or anything? – AM2FTW Dec 19 '17 at 10:50
  • It shouldn't be asking for the credentials, unless the site is not listed in the Local Intranet sites. Have you tried to add the site to the Local intranet sites like shown by AM2FTW answer? – Marc-André Dec 19 '17 at 13:48

There could be various reasons for it 1. IE internet settings, especially security - compare the set up of IE Internet Security options with users that do not experience issues (check set up of trusted sites, security logon options etc). 2. Time sync between the AD servers that Farm is connected to and the AD that the client machine is connected run the command W32tm /monitor /domain:yourdomain.com to determine if there is a time drift. 3. If none of those are valid review the Security Event logs on the server and client it should point to possible cause.

| improve this answer | |
  • Checked Sercurity Event logs. Didn't found any error – shoab Dec 19 '17 at 8:22

Is your site enabled for external access? I believe there is a setting for this. This would be relevant if the users, who are having trouble logging in, are external people (not from your company).

I'll add one other avenue of investigation - there is something called Single Sign On also know as 'SSO'. Although this sounds like it is a stage further than what you need to do at present - if people log in via the extranet path it makes a security prompts every time a user tries to download a document.

| improve this answer | |
  • Site is only for internal use – shoab Dec 19 '17 at 8:22

Our issue was a couple PC's had a GPO applied that changed the following setting: Computer Config > Windows > Security settings > Local policies > Security Options

Network Security: LAN Manager Authentication level: Send LM & NTLMv2 session security if negotiated

Had to change it to: Send NTLMv2 responses only


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.