Storage Quota is missing from my SharePoint Online admin center. Is this permanently taken away or i don't have permission to it?

I am in a SharePoint Administrator role.

1 Answer 1


On SharePoint admin center from left quick launch click on settings.

Make sure you Manual is set, if not change it to manual then click Ok.

enter image description here

Now if you go back to site collections page, select one site collection and you will see the quota option from ribbon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.