3

I have added two columns to a document library: "Version" and "Revision". Though I do see column headers on the document library page but the problem is that they are empty, even though some documents have had multiple edits and show, say, version 5.0 in the file's "Version history".

That is a standard word document library created on a Office 365 SharePoint site.

What am I doing wrong?

Thanks in advance.

enter image description here

3 Answers 3

1

Ensure that the columns are added from the existing OOB columns to the view rather than creating new columns.

Create a new view and show these columns on the view, see if the columns have values.

Also, create a new library and test it again.

0
0

navigate to library settings and validate if versioning settings are enabled under Document Version History section

0

Just to follow on from what Joanna said; a Document Library has a default 'Version' column already. There is no need to use 'Add from existing site columns', even though when you look at Library columns you won't see the Version column (yes, I also find this a bit weird, but c'est la vie):

See...no Version column: No Version column shows under Library Settings>Columns

And yet, when you go in to Create or Modify View, if you scroll down, you'll find Version skulking down the bottom there (see pic below) - just tick the box to add the Version column to your view.

Here is the Version column you seek

Also, as one of the other posters mentioned in their Answer, you'll need to enable Versioning Library Settings>Versioning>Document Version History>select Major or Minor Versions. Then, when you go back to view your document library, you will see a number appear in the Version column.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.