0

Created new document library and enabled 'Allow management of content types'. Created a new document content type, assigned columns to the CT. I've not done anything fancy or unusual. I've been using this video as guidance.

I used these settings for the content type:

enter image description here

I think the problem comes when I am trying to set a Word template to my new content type - I used this other video for guidance.

I've tried swapping the associated template doc from one with Quick Parts to one without, but it made no difference - same error.

Here are the error messages I see when I click on 'New Doc' in the ribbon and select the new template:

The operating system is not presently configured to run this application

error message - check settings, it's a long message

Thanks

Update 1: I found a similar post with a good answer. I have done all of the steps shown is this post, then I get the error message.

A 2014 post which has the same error.

0

Answer 1

The new templates I created and uploaded to the content type were saved using the wrong file type. I had saved them as myfilename.docx, but they need to be myfilename.dotx.

I used this Microsoft link to troubleshoot, here's a screenshot of the most important bit:

.dotx template must be used!

Thanks Microsoft for the vague error message, how about a message saying 'content type template file type invalid'. Anyway, also my fault for choosing the wrong file type.

Folks watch out - the tricky part of this is that users on Excel 2010 were still able to use the content type template despite it being in the wrong format! Whereas Excel 2013 users (like me) were not able to use it!

Answer 2

If Answer 1 does not resolve the issue, then the trigger for the error message could be the 'method' used to add a new item (a new content type item). To troubleshoot this, test the 'method' used to add a new item to the Document Library:

  • new item button in the ribbon (SP will add the default content type - check your default in the List Settings).

  • check for other options using the drop-down menu associated with the new item button (if you have multiple content types you may see them all by clicking on the little triangle, this would allow you to choose an alternative content type).

  • Try drag and drop in to the Document Library. Then edit properties of the file you have dropped, if there are Required Fields you will need to fill in a value before you can check in the document. You can also select the content type (if you are using multiple content types in the same Doc Library).

  • Try the 'Upload Document' button, I found this effective.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.