1

I have been working on this project for several months, and all of the sudden I cannot deploy the solution anymore. I am getting this error:

Error occurred in deployment step 'Recycle IIS Application Pool':  cannot 
connect to site https://blah.blah.blah. Make sure that this is a valid URL 
and the SharePoint site is running and so on...

I have done everything I have read to get this to work. Checked permissions, checked SQL access, reset IIS, recycled the App Pools, Check Central Admin and Site Collection Permissions, I run VS as an Admin, I mean everything; well obviouxly not everything or this would work right now.

I am working on a Claims based solution. I am not sure if this has something to do with it, or if it changed me somewhere on the farm. I can get to the farm through the URL and it is running just fine.

Edit: After checking the ULS logs, I am getting a Claims provider error on the custom solution's assembly, and I am also getting a security token request error. I am not sure what I did to get it to throw these errors, but for some reason SharePoint is rejecting my assembly for my solution.

Edit 2: Instead of carrying on in the comments, I will post here. I was able to deploy via powershell. When trying to access my WebApp I am getting Acces Denied which is expected right now, and another post in the near future. I am still puzzled as to why VS stopped deploying my solution and how my solution stripped my ability to launch from VS. Thanks for the help and suggestions!

  • are you deploying via powershell or directly from VS? what is your web application authentication confiuration? check the Event log and ULS log for more clue. – Waqas Sarwar MVP Nov 30 '17 at 15:41
  • I am deploying via VS and this is a Farm level solution. I have been working between two WebApps. One is a simple Windows Authentication, the other is a Claims-Based WebApp where I have my custom Claims provider attached to it. – lazoDev Nov 30 '17 at 15:45
  • try to add the user in the Policy of web application with full control, the user which is running Visual Studio. stuartroberts.net/index.php/2011/07/16/… – Waqas Sarwar MVP Nov 30 '17 at 15:46
  • I did already. I also run as an admin in VS. I also made my account a server administrator as well, which is not a great idea but needed to try something, still no dice. – lazoDev Nov 30 '17 at 15:51
  • have you tried to deploy it using the powershell, i am thinking due to your custom cliam providers it is not recognizing the ur account...did you check the ULS logs and event logs? – Waqas Sarwar MVP Nov 30 '17 at 15:55
0

I found that my issue was that my super user and super reader accounts needed to be reset. Once I removed and the re-added those accounts, everything started working as normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.