0

All of a sudden when I go to the default new form in a simple List the form appears from right side in a modal (does not redirect to NewForm.aspx).. Here(and also in NewForm.aspx) I see a new field Content Type with one option in dropdown menu Item. Why is it so? I used to set Allow management of content in List setting to Yes to change column orders but because of this there was never an issue. Have the settings been compromised? Kindly help!

I'm working in SharePoint online

Image for info

UPDATE With Classic SharePoint experience this problem does not appear

0

Go to ListSettings->Advanced Settings and change the value for "Allow ContentType management" to "No". If you now create a new item, the dropdown will not be displayed.

If this answers your question, please mark as answer.

  • No buddy. Setting ContentType mngmt to No does solve the problem BUT in past even with Yes selected no such field used to appear in new form. I think it's with the new user experience.. because in classic SharePoint this problem is not present. Yes or No if its classic Sharepoint experience u're viewing ALL IS GOOD! – akg1421 Nov 30 '17 at 5:37
0

You can hide this field in PowerApps, but then I am not sure that you will be able to use several content types. Moreover when you change content type while creating new item set of fields assigned to this content type will not be updated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.