1

I've got a brand-new 2016 environment that is having some authentication issues. Currently, I cannot open the (only) site in SharePoint Designer, nor can I edit its forms in InfoPath. When I try, I'm delivered a blank error message (as described in this blog) and Fiddler records multiple 401 responses.

This seems to be a common problem, but the wealth of answers out there have not worked for me. So far I've ensured that IIS has proper authentication providers enabled, enabled anonymous access in CA, disabled the loopback check in the registry, set up AAM to accept the hostname and the FQDN, and ensured several options in the web.config aren't interfering (as referenced by posts like this one and numerous others around the internet).

What next steps can I take? ULS logs are just showing a generic "Access denied" message that doesn't help, and I've tried multiple accounts that are owners of the site and/or site collection. I'm a little stumped at this point.

1

You could go to check if SharePoint designer is enabled in central administration.

Go to central administration->manage web application->select the web application which holds the site collections->click general settings in the ribbon and select SharePoint designer->select enable SharePoint designer->save changes.

enter image description here

enter image description here

  • I did actually check that, it's enabled :/ – thanby Nov 29 '17 at 18:27
  • Go to the problematic site ->site settings-> Site Collection Administration-> SharePoint Designer Settings->check if all are selected. – Amy_MSFT Dec 15 '17 at 9:30
0

I'm hesitant to mark this the answer but it's what led to the problem being solved. There are two different names for the same domain on this network (not entirely clear on how that happened), so FQDNs are "Domain.com" but the domain name is "DomainAD". Subsequently, different web apps require you to use one or the other depending on how privy they are to the existence of both.

It's my guess that SharePoint was choking on that difference, because as soon as I added both possible names to AAM, it started working.

Once again, I can't say for certain that's what was wrong, it's just my educated guess. If someone out there knows the truth, please verify or post your own answer.

Edit: Marking this as the answer for now. If anyone has another explanation or solution, by all means add it and I'll consider it to be the better answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.