0

My problem is that I can't simply share any site with any user. A couple of weeks ago I started creating a site collection and adding content to it. Once finished, I duplicated this site collection into different content databases for every client's department.

Today, I thought everything was fine, until I noticed that when I try to share a site with any user, that user always receives "Sorry, this site hasn't been shared with you", which is false, I shared it to that user.

I googled and have tried everything but I can't solve this. I did a simple test, which was to create a completely new site collection, share it with a normal user, and user can, of course, access. If I stop sharing, user cannot access to this test site collection. ¿WTF?.

So, with that test, my guess has been that the problem is in my original site collection. Consequently, every duplicated site collection has the same problem, and I don't know why the original site collection has this problem.

How can I solve this? Anything to test or debug? This is a really weird and worrying problem because I cannot simply share a site with a user in my SharePoint project, which has taken me a many hours to create.

Thank you.

  • Is ur original site collection is a publishing site? What level of permission you are assigning? Did you configure unique permission or create custom permission level? – Waqas Sarwar MVP Nov 20 '17 at 20:51
  • @WaqasSarwarMVP Yes, it is a publishing site, it's the default template I always choose when I create a Site Collection. I have tried all levels of permission, like owner, visitor and integrant (member) and at the same time too. I also tried creating a custom permission level. – Sergio Nov 20 '17 at 22:34
  • Check if style resource reader and restricted groups are in that site collection.also make sure everyone should b part of that group. – Waqas Sarwar MVP Nov 20 '17 at 22:45
  • @WaqasSarwarMVP Sorry, I confused, my sites collections are Team Site, so those groups aren’t in my SP 2013 Foundation I think. Btw, I also tried Anonymous login and it didn’t work – Sergio Nov 20 '17 at 23:36
  • 1
    What authentication method is being used? Use the f12 developer tool and check on which component 401 occurring...do u have any link on home page from different site or any reference where user don't have permission, what happen if you make user secondary site collection admin. – Waqas Sarwar MVP Nov 21 '17 at 0:35
1

There could be many things which can cause this issue.

  • Mostly this happen when publishing template is used. User change the permission for style resource reader and restricted reader groups.

  • Or you have unpublished page...

  • some case if you have add some content / links/ webparts which pull data from different sites then user gets access denied...because they don't have access to content from other sites. I think this is you issur.

0

Check the default permission for Style Resource Readers group that includes “Everyone” and “NT AUTHORITY\authenticated users” on Master Page Gallery. By default, this group should have “Read” permission on Master Page Gallery.

enter image description here

0

@WaqasSarwarMVP was right.

In the home page of my site, I have a custom developed WebPart by myself which gets documents from a couple of libraries from other site collections, so this user had to had permissions for these libraries, which it didn't have. That's why I was given: "Sorry, this site hasn't been shared with you".

Once given read permission to the user to the appropiate libraries in every site collection, problem is solved.

Thank you Waqas. Credits to @WaqasSarwarMVP.

  • Great, I just added that as answer, please mark it as answer and upvote. Thank u – Waqas Sarwar MVP Nov 21 '17 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.