0

I have a really weird issue. I have created a new Custom List with the default List content type. When I attempt to add a new item, a blank page is displayed. The NewForm.aspx page does not display any of the default fields (Title, Modified, Modified By, Created, Created By). I have tested to see if I add a custom column if any fields display. I can verify that a custom column displays, but none of the other default fields.

This site was recently migrated/upgraded from SP2010 to SP2013 On Premise if that helps.

  • **Additional Notes: By default, the 'Title' field is marked as 'required.' Apparently, unchecking the required option made the 'Title' field display. Still, this is weird as I cannot recall the Title field being required rendering a blank newform page. Any thoughts/ideas welcome. Thank you. – user2004758 Nov 20 '17 at 14:46
0

The following fields are intrinsic metadata and will only display in a list’s “Edit” and “Display” forms: Created, Created by, Modified, and Modified by. That information isn’t saved and available for display until after a “New” form is saved so those details will not display in a "New" form.

However, it does seem strange that the “Title” field didn’t display until after you made it not required. You could try creating a new “New” form for the list in SharePoint Designer. Steps for creating a new “New” form are below.

  1. Open the site in SharePoint Designer.
  2. In the Navigation panel, click Lists and Libraries.
  3. Click the name of the malfunctioning list.
  4. In the Forms section, click New.
  5. Enter a File Name, leave New item form selected, select Set as default form for the selected type, and click Ok.
  • Thanks, yes I was going to do that but wanted to make sure if the issue could be replicated in all instances of new Custom Lists. The answer is yes, so I'm assuming this is a weird issue related to something going wrong on the SharePoint Server side. – user2004758 Nov 20 '17 at 18:24
0

I actually figured out what the issue is. It was a system side issue. By default, the Item Content Type has the 'Title' field set to hidden, therefore it does not display on Forms. Changing its Column Settings corrected the issue.

As an aside, if anyone is reading, I can't recall that the 'Title' field has ever been in a '_Hidden' fields group or that the 'Item' content type has only ever had one column defined for it: Title by default. Are these settings standard to an OOTB SharePoint deployment or did the farm administrators that deployed our SharePoint Enterprise use best practices? Just seems weird.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.