0

Can anyone suggest how I enable the out of the box control display template, List with Paging?

In a SharePoint 2013 environment, in the web part settings for Content Search web parts, the out of the box control display template “List with Paging” does not appear as a choice in the Control drop down. The other out of the box control display templates are available (List and Slideshow).

I’ve verified the following for the out of the box control display template (Control_ListWithPaging.html): 1) It is in the Master Page Gallery in the Display Templates folder, and 2) both it and its associated js file are Approved.

1

Looks like somebody has modified this template and might have accidentally changed it properties.

To fix that, in your browser,

1) Go to Master page gallery > Display templates > Content Web Parts

2) Edit the properties of Control_ListWithPaging.html file.

3) Ensure that the content type is set to Control Display template

4) Ensure that Hidden template checkbox is unchecked.

5) Ensure that Target Control Type(search) has Content Web Parts field checked.

Check the below screenshot.

enter image description here

If these properties are not set, it will not show up in the dropdown of content search webpart.

After you modify the properties, check-in and Publish a major version of this template.

  • Thanks for the reply, Gautam. Unfortunately display template properties are not the problem. The "Hidden" field is deselected and the appropriate values are selected for the "Content Type" field and the "Target Control Type (Search)" field. – Jenny Hersko Nov 20 '17 at 15:02
  • Hmm interesting. Can you deactivate the publishing features (both, site collection and web ) and activate them again and check ? – Gautam Sheth Nov 20 '17 at 15:13
  • The List with Paging control template is now available for use. I resolved the issue by checking out the Control_ListWithPaging.html file. I selected the “Hidden Template” field, checked in the file, and approved. Next I checked out the file, deselected the “Hidden Template” field, and re-approved. – Jenny Hersko Nov 20 '17 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.