The site I'm working on uses folders inside the Pages library (yeah, I know and agree.. but they pay the bills). When searching for key terms, I'm not getting the pages within these folders in my results.

Initially I think I was, but I added some crawl rules to hide list items, list forms, etc and having reset my index and done a full crawl, I only get pages that live in the Pages library itself, rather than within folders in that Pages library.

I removed my crawl rules, reset the index again (thankfully this is a dev site, not production) and I still only get pages, not folder/pages.

This is true with osssearchresults.aspx as well as my custom results.aspx file (which is essentially the ootb page with a different master)

Any ideas of what I can do to allow folder/page style results? I swear this was working before I add/removed the rules.


[Updated to provide more info]

My site structure matches this example



Each of the pages within the us Pages library mentioned product1 in some way. So, when I search for product1 I would expect to see results for all 4 of the pages within that library, listed above.

What I see is just


no /us/Pages/default.aspx or any pages within the products folder inside that library.

strange, right?

  • 'us' is a subsite, yes?
    – James Love
    Commented Nov 10, 2011 at 19:29
  • yup. '/' is the site collection and 'us' is a site
    – QMKevin
    Commented Nov 10, 2011 at 19:43
  • In Site Actions-Site Settings, there's an option somewhere under Site Collection Administration (at the top site level) that lets you set Search Settings, check to make sure that pages in that site are allowed to be indexed.
    – James Love
    Commented Nov 10, 2011 at 19:45
  • I feel foolish now.. apparently the crawl rule ://*webfldr.aspx was the problem. I'm not exactly sure why, as in my mind this was looking for a specific page name, but it seems that there's some underlying oath structures that I'm not aware of that this rule was catching. Thanks for your help, James.. It's much appreciated. I'm going to mark your answer below as correct, so that others who see this thread in the list don't pass it by.. there answer IS in here - this comment
    – QMKevin
    Commented Nov 10, 2011 at 20:35
  • That's excellent knowledge. Will definitely keep that to one side for future reference!
    – James Love
    Commented Nov 10, 2011 at 21:15

2 Answers 2


Have you published and approved the content within the folders (and the folders themselves)? The crawler shouldn't index non-approved content.

  • Yeah, all the content I'm expecting is published and approved, including the folders themselves (I found that out the hard way). I'm still playing with the index, but I'll prolly have to pick this up tomorrow.
    – QMKevin
    Commented Nov 9, 2011 at 21:57
  • So, morning is here and I'm looking at this again. Overnight my incremental index ran, and some issues were fixed (automagically), such as Best Bets showing duplicate - now they show just single results. However, the folder issue does still exist. I've checked all the expected pages again, and they exist, are approved, etc. but still won't show up in search results.
    – QMKevin
    Commented Nov 10, 2011 at 16:53
  • Peculiar. See if you can log into the site using the content crawling account (visible on the Search Admin page), and browse the content. Also, are there any Scopes in play?
    – James Love
    Commented Nov 10, 2011 at 16:57
  • Good idea. I can log in using the 'System Account' (which is the one shown in the Search Admin page), and I can browser to all the expected content. I'm gonna update the original question with an example of the site structure, to give a clearly understanding of what I'm seeing and what I'm expecting.
    – QMKevin
    Commented Nov 10, 2011 at 19:17

I had the same problem here. We have an Enterprise Wiki with folders in the Pages library. We also have versioning and content approval activated on this library.

The crawler ignored files (Wikipages) in folders which haven't been published/approved yet.

After manually setting the Approval status to "Approved" on the folders the crawler found every page in it.

Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.