0

I just set up a brand new single-server 2016 environment but have run into a puzzling issue with it. Any site collection and sub-site I create have blank home pages with only the SP icon, top nav, and ribbon, and when watching the traffic with Fiddler I'm seeing a couple 301s, 401s, and a 404 when the page loads. In addition, the People Picker gives The account I'm using has full control of the sites.

I've done all the basic checks to ensure services, application pools, IIS sites, etc are all running and using proper accounts, and I've triple-checked permissions. I've also tried this People Picker fix involving HTTP Activation features, but it didn't help either. I'm kind of stumped at this point. Does anyone have an idea where I should look next?

Update: Another puzzling piece I just noticed is that when trying to access sub-sites, I get redirected to a 404 page on the top-level site. After getting the 401, it then sends a 302 titled "Document Moved" and a notice about the URL having changed. I don't actually see it on screen, it just shows up in Fiddler. What daemonic hex have I accidentally put on this environment?

  • did you check the ULS logs what's in it? did u apply any updates? whats the status of the Server from Central admin > system setting > manage server in farm? – Waqas Sarwar MVP Nov 17 '17 at 15:06
  • Are the servers set up with the correct amount of cores and RAM? Sounds like the sites are incomplete when created as you have a timeout of some sort. – Christoffer Nov 17 '17 at 15:22
  • @WaqasSarwarMVP It's version 16.0.4327.1000, which I'm pretty sure is just the out-of-the-box one. The server looks fine in CA, everything there works except that I have to point to localhost instead of the server name, otherwise DNS returns an IPv6 address. ULS is showing "Cannot find site lookup info for request Uri server.domain.com" but that's pretty much it. – thanby Nov 17 '17 at 15:50
  • @Christoffer The server does have the correct hardware, 4 cores and 24GB of RAM on a VM. The sites do look half-created but I think that's because of the 401s I'm getting. If I try to add an app or navigate to a sub-site I also get a 401 but it's for the entire page, not just part of it. – thanby Nov 17 '17 at 15:53
  • Did you only try to create site collections using the UI? Tried with Powershell? – Christoffer Nov 17 '17 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.