5

After creating a new project with SharePoint generator I can not connect to my workbench on localhost (ERR_CONNECTION_RESET) via HTTPS!

I have tried numerous changes in internet settings and in Visual Studio Code, but my localhost (http://localhost:4321/temp/workbench.html) is not responding.

Have tried with browsers like IE11, FireFox, Chrome.

Any ideas which settings I have to change?

Thanks in advance for any help.

1
  • I had this issue. I tried every possible things and it never worked. I ran this command npm install gulp -g. It started working. Jan 15, 2019 at 1:22

2 Answers 2

10

you can avoid your problem by using http instead of https
To do that, in

config\serve.json

set

"https": false,

and remove the "s" from the URL in the "initialPage"

Save the file, restart "gulp serve" and the workbench will open in your browser using http

6
  • Whoaw - that exactly helped, my workbench is working now. You made my day!!! @user1730 thanks a ton! Nov 14, 2017 at 14:58
  • Possibly you missed adding Dev certificate using NPM. That was a part of the tutorial, that is why with https you were probably getting trust issues.
    – mohd tahir
    Nov 15, 2017 at 10:13
  • Thank you @mohdtahir - I had tried "gulp trust-dev-cert" before as well - but that did not fix the issue. Nov 28, 2017 at 15:53
  • any other fix,it doesn't work for me Dec 2, 2018 at 16:25
  • maybe setting NODE_NO_HTTP2=1 will help, see github.com/SharePoint/sp-dev-docs/issues/1002
    – user1730
    Feb 12, 2020 at 11:56
1

This can also be caused by something else on your system that uses port 5432.

This resolved the issue for me:

I changed the port number in config\serve.json.

In the screen shot below, I changed the initialPage port from 5432 to 5437. I also changed the port in the api section to 5437.

I left port 4321 alone.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.