1
  1. I am the Global Admin on our Sharepoint 365 site.
  2. We have "Sharepoint Publishing" turned on (not really sure why).
  3. We recently migrated from Sharepoint 2007 to Sharepoint 365 using Sharegate.

When i go to any page and in the top ribbon click on the Page tab the Edit Page button is disabled. I tested this for several pages on the site.

I also tried creating a new Page. This worked. Also for the new page the Edit is enabled.

Any ideas how to restore my site?

enter image description here

1

Go to the pages library which contains the pages you cannot edit, select and right click the page, click share with->advanced.

Click “check permissions”, check if the “add and customize pages” permission is denied.

If so, use SharePoint Online Management Shell as administrator to enable custom script settings.

Reference: Allow or prevent custom script

  • in the pages library there is only one file. am i looking at the right place – codeNinja Nov 15 '17 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.