2

I am using Sharepoint 356 (office 365). I recently migrated my site from sharepoint 2007 to 365.

I used to have a calendar on my homepage that had 5800 items. Office 365 view limit is 5000. So the calendar view does not show any items. It just shows this error message

This view cannot be displayed because it exceeds the list view threshold (5000 items) enforced by the administrator.

To view items, try selecting another view or creating a new view. If you do not have sufficient permissions to create views for this list, ask your administrator to modify the view so that it conforms to the list view threshold.

I have clicked on "Modify View" and then set Created as [Today]-5 which should lead to 5-10 entries. Yet on the homepage where the calendar should show the error continues to be displayed.

Why is this not taking effect?

NOTE: that i am not using Team Site. Still using the old UI of sharepoint. If i click on the View Name the next page successfully shows the items.

enter image description here

11
  • Can you check if Created column is indexed or not ? Nov 17, 2017 at 4:43
  • I agree with @MonicaJagani - could you make theCreated column indexed and retry?
    – Sergey
    Nov 17, 2017 at 16:44
  • Created is an indexed column
    – codeNinja
    Nov 17, 2017 at 21:58
  • Are you doing this in IE? Nov 21, 2017 at 12:48
  • Can you provide full CAML for the view here? There could be a hint. Also, try filtering by ID > 1000 or smth like that. Nov 21, 2017 at 18:59

3 Answers 3

1

Changing the view is not sufficient, you also have to add an index to the list. List settings -> create an index

1
  • created is already an indexed column.
    – codeNinja
    Nov 17, 2017 at 21:59
1

Clarification questions... (too many characters for a comment)

  1. Can you toggle to another view without getting the error?
  2. For list indexing, try creating additional indices (event name, start date, category, etc).
  3. For Page Editing: Can you navigate to a separate page and go into edit mode? I'm assuming this is a publishing site collection. If not, try navigating to the culprit page via Site Contents/Pages or Site Pages, select the ellipses and check the page properties, permissions. SP Online has recently enabled a timeout function so if you're using a stale browser instance, the page may show as checked out to you, while not letting you edit. If/when you see that, do a force refresh.

As a fallback option:

Lists created in O365 can have up to 20 million items with defined views and indexing applied. I'm not sure what the success stories are for migrated lists vs imported into new lists. Your list is behaving like a remnant.

You probably still have migration tools handy. An option to consider is to create a new calendar in the new environment, then migrate the data from your old calendar over. Sharegate or something like it are great, especially if you already have defined content types or metadata.

I've had to do this with a few lists post-migration for various reasons, and it's not as painful as it sounds (if you have the tools for the job).

Good luck -

6
  • I have tried going into edit mode. It says "You are editing a personal version of this page"
    – codeNinja
    Nov 22, 2017 at 3:12
  • Ok, that sounds like you are signed in as a general users. All O365 users have the option to 'customize' the way they see their pages (to a degree, unless that's been turned off). This wouldn't happen if you're signed in on a global admin account. Can you go to the O365 Admin Panel, click on Users, type your name, and see what access you have? If you don't have admin access, you won't be able to log into the O365 admin panel. It sounds like you are on the right path, just not using an admin level account. I hope that helps -
    – KRobison
    Nov 24, 2017 at 3:49
  • I checked my users permissions and it says "Global Administrator"
    – codeNinja
    Nov 26, 2017 at 0:10
  • If you are seeing "you are editing a personal version", then you only have Contribute rights to that site. That would explain why the item limit issue is not fully resolving. Global Admin reflects your O365 permission level; this is not the same as your SP permission level. That depends on how your SPO permissions are defined. You'll need to be in the Site Owner SP group / Full Control to manage the list and its view administratively. Check also at the Site Collection to ensure you're in the Site Owners group.
    – KRobison
    Nov 27, 2017 at 16:46
  • For more information: support.office.com/en-us/article/…
    – KRobison
    Nov 27, 2017 at 16:46
0

You need to modify the view the calendar webpart is using.

  • Edit the page

  • Put the webpart in edit mode

  • Modify the view and apply the filter

  • Save the page

5
  • interesting... the Edit Page is disabled for me. But i am the Global adim... Any idea?
    – codeNinja
    Nov 12, 2017 at 15:08
  • Are you accessing it via the settings menu at the top right?
    – Marmalade
    Nov 12, 2017 at 15:10
  • no. i was doing it via the toolbar that shows at the top of the page. it has ` Browse, Page, items, list` in the top toolbar. in the page ribbon the Edit Page is disabled
    – codeNinja
    Nov 12, 2017 at 15:18
  • In the list tab of the ribbon there is an option to modify the view there. Is that available to you?
    – Marmalade
    Nov 12, 2017 at 15:48
  • yes. "Modify View" is available. I have already tried that. It does not change anything. I used it to specify created is greater than [Today]-5
    – codeNinja
    Nov 12, 2017 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.