I am not able to retrieve list items due to it has crossed threshold limit. The number of items in the list is 150000 and I am trying to fetch certain items filtered by a field value(say 'pincode'). Such matched values are not more than 20; Still, I am getting error of 'Threshold limit'

Please check my steps and let me know if I have done anything wrong.

  1. Created SP List.
  2. Created columns One of the columns is 'pincode',
  3. which I create as Index column (primary index).
  4. upload excel list data into sharepoint list using powershell.(around 150000 entries)
  5. The written code in javascript to fetch List data filtered by 'pincode' with a particular number (say 110015).

Here is my CAML Query

<Query><Where><Eq><FieldRef Name='pincode' /><Value Type='Number'>110015</Value> </Eq></Where></Query>

Error after operation failed:

"The attempted operation is prohibited because it exceeds list view threshold enforced by the administrator"

It would highly appreciable if someone could give a solution.

  • I had the same problem. Got the solution here sharepoint.stackexchange.com/questions/214795/… Commented Nov 10, 2017 at 11:47
  • Does the error come up when you just open the list or when you start filtering the list?
    – dns_nx
    Commented Nov 15, 2017 at 20:07
  • @dns_nx As I mentioned in my question I did all those steps provided there, still, I am getting the error.
    – Akhilesh
    Commented Nov 16, 2017 at 4:08

2 Answers 2


Try to set a limit in your fetched data.

        <FieldRef Name='pincode'/>

Go to central admin and increase threshold:

  1. Choose your web application and click on ribbon drop down in general settings
  2. Choose Resource Throttling.
  3. Increase List View Threshold param
  • 1
    If number of items are somewhere around threshold limit (say 6000-7000) then it is fine although it is not recommended. But number here is 1.5 lacs. There must be some other solution.
    – Akhilesh
    Commented Nov 10, 2017 at 11:16
  • Ok, try to use row limit or content iterator Commented Nov 13, 2017 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.