0

I have a question which I couldn't figure out why. I created a new list in a different subsite and I tried to use Content Search query to return the list item in that list by using query like:

ListId:ListIdA

ListIdA is retrieved from

http://intranet/_layouts/15/listedit.aspx?List={Id here}

But when I tried to use another ListIdB from an existing Content Search Query, it works fine.

Could anyone point to me what I am missing, please?

In the Content Search Query I noticed the Refiner list is empty, but for the working one, it has quite a few filter I can choose. Not sure if it is related.

Thank you.

0

check the following things:

  1. Check you have allowed items from this list to appear in search results.

    List settings > Advanced settings > Allow items from this list to appear in search results > Yes.

  2. Check if you have permissions on this list to view items.
  3. Go to Central Administration, check the crawl log to see if the items within this list are crawled.

    Central Administration > Application management > Manage service applications > Search service application > Crawl Log

  4. Go to the Search Service Application > Crawl Rules, check whether there are some rules to exclude this list.

  5. Run a full crawl and ensure it is complete and the list is crawled successfully, and then check if you get results.
  • 1.Yes, it is enabled by default. 2. I created this subsite and list using my account, so it should have full access. 3, 4 and 5. Don't have access yet, but would try to see if can check the Crawl log. – Xiao Han Nov 10 '17 at 20:46
  • Run a full crawl and check if you can get the results. – JoannaW_MSFT Nov 13 '17 at 1:23
  • For 3, after I go to Central Administration > Application management > Manage service applications > Search service application, I can see the Crawler showing a red cross for one of the app server. But when I try to acess the Crawl log/Content Sources/Crawl Rules/Pause or Resume, it gives me an error: System.InvalidOperationException: The search service is not able to connect to the machine that hosts the administration component. Verify that the administration component 'b4f8b48c-013e-4e9b-b981-64a4e4bd9cf7' in search application 'Search Service Application' is in a good state and try again. – Xiao Han Nov 14 '17 at 15:24
  • And in IIS->SharePoint Web Services, I couldn't find this mentioned component using the GUID. Any idea why? – Xiao Han Nov 14 '17 at 15:25
  • I checked Crawl Log, Rules and settings, they are all good, from the Crawl Log history, I can see all the lists I created showing in the crawled history. Anything else might cause this? I am running a full Crawl now. – Xiao Han Nov 14 '17 at 19:12
0

JoannaW_MSFT's reply gives the direction and help to solve the problem.

I still didn't figure out exactly what happened. As nothing showing wrong in the Crawl Log, Crawl service is running, nothing else is configured to stop the contents being crawled.

But after did a full crawl, the log still shows the same, but I can search the List in Content Search web part now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.