2

I have created a site column which is a multi-text field. When I search on my Search Results Page, it is showing the List Items which has search keyword in this Site Column. I removed the crawled property mapping for the automatically created managed property. I also updated the Searchable Columns to exclude this column. I reindexed the List as well as Site after these changes. I want to avoid the full search crawl. Is there any else I am missing here?

2

Per my test, I exclude the custom site column in the searchable columns settings and start an incremental crawl, then the search result doesn’t contain the list items which have this column value, but it still returns the list name which contains text.

enter image description here

Whether you encounter the same issue as me?

If so and not want to return the list name as result, as a workaround, try to filter to exclude the list result in the search result:

Go to Central administration site->Manage service applications->Search service application->Result sources->find the default result source in the list such as “Local SharePoint Results” and click Copy->click “Launch Query Build”->select Only return items and click Add keyword filter->save this result source and set as default.

enter image description here

Finally, the result not return the list as below: enter image description here

  • Did you run full crawl post your changes? – John Zachariah Nov 9 '17 at 12:55
0

Hope you have followed this one.

Exclude content in columns from search results

As a site owner you can control whether the content in specific columns in lists or libraries appears in search results. By default, all content is included in search results. This setting is useful when you want to prevent sensitive data from appearing in search results.

NOTE: To change this setting, you must have the Manage Permissions permission level. This permission level is included in the “Site Name” Owner group.

  • Navigate to the site that contains the list or library.

  • Click Site Actions, and then click Site Settings.

  • Under Site Administration, click Searchable columns.

  • In the section Excluded Columns from Searching Indexing, under Excluded check the box next to the Column Name for the column you want to exclude in search results.

In Order to make any changes need to take effect from Crawled or Managed Properties, you need to have full index then only it will give you the exact result that you are looking for.

In case you are looking for some workaround then you can customise the search results templates to hide the data from showing but come up in the result.

Or you can try @hellofiona 's answer too.

Its worth looking at this post too. Sharepoint 2010 search - ignore a column

Reference: How to Exclude content in columns from search results

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.