2

I have a Document Set and have customized the Welcome Page. I'd like to remove the 'View All Properties' and 'Edit Properties' links from the Document Set Properties Web Part. This seems like it should be simple, but I cannot figure out how to do this. Is it possible?

Most of by Document Set properties are used in managing the workflows of our project coordinators. I do not want the team members that actively use the folders to 1) be able to edit any of these static properties or 2) be overwhelmed or confused when they see properties that they don't understand.

Is there a way to remove the links? I have SharePoint Designer 2013 and SharePoint Online and am a site administrator.

1 Answer 1

1

You can do it with a few lines of css.

  1. Open the site in SharePoint designer and navigate to All Files/YOUR LIBRARY/Forms/Document Set/docsethomepage.aspx
  2. Check out the docsethomepage.aspx file and open it for editing.
  3. Paste the following code just before the last closing </asp:Content> tag:

    <style>
    #ViewPropsLink { display:none; }    
    #EditPropsLink  { display:none; } 
    </style>
    
  4. Save the file and check it in.

Of course, any other way of injecting this css into the page should also work.

2
  • Thank you, this is incredibly helpful! How do I publish it as a major version? I saved the page and it works, but then if I make a change to the document set homepage in the browser, the View Properties and Edit Properties link reappear. I'm guessing this is related to me not publishing it as a major version, but not sure how to do that. Thanks!
    – Julie
    Nov 9, 2017 at 19:04
  • I've updated the answer. I double checked the part about publishing the major version of the file and it looks like it just needs to be checked back in (there is no option for choosing minor/major versions). I guess that when you edit the welcome page in the browser it just reverts back to default content so this css gets lost. So you should do this again from the SharePoint designer if you need to edit the page in the browser again.. Nov 9, 2017 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.