2

I've got a generic list with a multi line text field, that is set to plaintext. When I view the list or edit a single item, everything is fine. When I change to quick edit mode and write a text with line breaks, still everything looks normal.

But as soon, as I am in quckedit mode and not editing this field anymore, the line breaks are displayed as <br>-tags

before and after leaving the cell

After ending the quick edit mode, the field is displayed correctly again. But when I turn quick edit back on, the <br>-tags are displayed again.

Is this a known bug? Is there a fix for it?

1

This is not a bug. SharePoint renders everything in HTML on the page. When in edit mode, the column code is displayed. One way to get rid of this, and allow HTML to be rendered in the column, is to open the view in SPD, find the column, in the XSLT find the <xsl:value-of> node in relation to your column and add the disable-output-escaping = "yes" property. This will allow HTML to render in the column and get rid of the tags. You will have to do this on every list view with HTML in the columns.

  • 1
    Sorry, but I don't get, how this shouldn't be a bug. SharePoint has to encode line breaks when saving either as CR or CRLF or <br>, I don't care, but when outputting the value it has to decode them correctly. If not, that's a bug. – Hinek Nov 7 '17 at 13:31
0

This behavior of Quick Edit appears to be with a library and not with a generic list on SharePoint 2013 both o365 and on-premises.

In a list, the Quick Edit mode allows the multiline field to be editable via "Edit Source". However the "Edit Source" is not available in a library.

  • That is not correct, we are using SharePoint 2013 and this behaviour appears in a multiline textfield (plaintext) on a generic list. – Hinek Feb 28 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.