0

I have a custom SharePoint list with an InfoPath form used to submit and edit items. The form works just fine for submitting new list items, however when our users revisit the list item to either view or edit it, the text gets cut off. I ensured that the field was multi-line and plain text for the list settings. Additionally, I made the size of the text box larger, and turned on multi-line in the properties, however it's still cutting off the text after the first line. When I do actually try to edit the list item, only the first line of text is present and the rest of it is not present. What am I doing wrong?

Picture showing the text cut off

1

In InfoPath Designer, replace the field control with "Rich Text Box" and right click the control, select Rich Text Box properties "Display", enable the "Wrap Text" like below:

enter image description here

Finally, redeploy the form to list and it will wrap text for long characters when viewing the item:

enter image description here

Reference from MSDN: Specify the text-wrapping options for a control

1
  • thank you. It's too bad I can't get the words to display like this with plain text. Your solution does work, however it leads for a less than desirable experience for the end user when they try to click on a drop down box while the cursor is still in the enhanced rich text box. I have made these changes though as it seems it's my only option for the words to not disappear.
    – Jake H.
    Nov 2 '17 at 13:16
1

Per my test in my SharePoint online environment, I create a custom list, add the multiple line of text column and customize the form in the InfoPath designer.

No matter the multiple line field is plain text or Enhanced rich text (Rich text with pictures, tables, and hyperlinks), it will not cut off the text from multi-line as the picture in your post. It can work fine.

If the multiple line field is plain text, when customizing the form in the InfoPath designer, right click the multiple line field and select the text box properties. In the display tab, make sure the “Multi-line” is selected.

If the multiple line field is Enhanced rich text, when customizing the form in the InfoPath designer, right click the multiple line field and select the rich text box properties. In the display tab, make sure the “Wrap text” is selected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.