Has any else had this problem in a document library or list where you get the visual highlight cue that there's missing required information, but no required information is missing?

Reports Library

I've double checked the settings on both lists that this is happening and I'm not hiding any required fields. In the attached screenshot, the Title field isn't visible, but it's an optional field.

When I open the details pane, it briefly says it's missing required information while the content loads. If I use the details pane to re-fill out information, the missing required info highlight disappears for that item, but comes back after I refresh the page.

enter image description hereenter image description here

Does anyone else experience this?

1 Answer 1


Per my test in my SharePoint online environment, the details panel can work fine in the modern UI by clicking the two buttons in the picture below. enter image description here

Did the issue occur in all document libraries?

To troubleshoot the issue, check things below:

  1. Add the site into the trusted site in IE.

  2. Reset the IE. Go to IE->internet options->advanced tab->reset.

  3. Switch to other browser to check the result.

  4. Switch to other computer to check if the same issue will occur.

  5. Create a new document library to check if the same will occur.

  • After performing these troubleshooting steps, I've found the issue remains with all of the above except for a brand new document library. I also found that the missing information highlighting goes away if all required columns are visible in the view. In my library, both Name and Report Name are required. If either of those columns are not in the view, I get the highlights about missing required information even though they are both populated.
    – Garett
    Commented Nov 1, 2017 at 12:14
  • You could make sure that the required columns are in the current view to avoid the missing information highlighting. If the reply is helpful to you, you could mark the reply as the answer. Thanks for your understanding.
    – Amy_MSFT
    Commented Nov 1, 2017 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.