1

I have a problem in a lists datasheet view. It's a regular issue list with a custom content type added to it. In the content type, there are 9 fields that are set to require information. When I checked every single list field the only field that was required was the title field. So when I used datasheet view and added an item it worked fine just filling out that field.

But I wanted all 9 fields to be required in the datasheet view too, so I updated those fields to be required in the list. The validation works for those fields in the datasheet view but when I have filled all required columns with data it won't save. I got the error message: "columns that require data are not included in this view.......".

Now I am stuck, don't know what to do? I have triple checked every column in the view. Have tried to add every column available in the view but it still complains?

Please, need help?

0

Have you checked in the Content Types section of the List Settings? Inside a Content Type a column can be marked as Required. The Content Types menu is located just above the columns.

It's possible that there is more than one Content Type, in which case I would be inclined to check all of them to see whether they have required fields.

If this doesn't fix your issue, then it could be that the form has been customised. In Sharepoint there are 3 forms (new/view/edit). It is possible that a Required column is missing from your form.

  • Thanks for your reply, my list only have one content type attached and in the content type there are 9 columns that are required and when I check in list columns under list settings the same columns are required. And in the datasheet view I have all these columns but sharepoint still complains that about columns missing in the view? In standard NewForm it works just fine. I don't understand what is wrong? – kethor Nov 1 '17 at 8:31
  • you could try testing to identify if it is one column that is causing the problem. Try setting just one column to Required. Then add a new item and enter the data. Does SP allow you to save the item? If it is ok, go back to List settings and set another column as Required. Then add a new item. – Tally Nov 1 '17 at 10:26
  • I solved the problem. I printed all fields from the list into a textfile and with the required property value from every field. Then I found that there was a field that had required true, but the column was not available from list settings. I changed it programmatically and now it works. Thanks for your help Tally. – kethor Nov 1 '17 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.