0

I have a OneNote notebook that is uploaded to a SharePoint library (SharePoint 2013 Foundation). When I try and attach a file by dragging and dropping it into OneNote, I get a popup asking if I want to copy to sharepoint and link it in OneNote:

enter image description here

If I choose to do that, I get this message:

enter image description here

The file I'm copying is more than 50MB (it's 52MB) - where can I increase the attachment size limit? Most of my googling has lead me to the Web Application general settings where I can see the maximum upload size is set to 250 MB so that can't be the right setting.

enter image description here

I was able to upload it directly to the library the notebook is in, however I do get a warning that the file was blocked (it's an executable .msi)

Edit: I also found these steps:

Make a backup copy of the web.config, then open it Do a Ctrl+f to find this element

<httpRuntime maxRequestLength="51200" requestValidationMode="2.0" />

Modify the above element to match the following

<httpRuntime executionTimeout="999999" maxRequestLength="1024000" requestValidationMode="2.0" />

and do an iisreset but no luck so far. Sharepoint still refuses the attachment because it's bigger than 50.0MB

1

The issue was that the file was a .msi which is not allowed by default. OneNote didn't seem to be displaying the correct error message.

First: I made the file size change, setting maxRequestLength="1024000"

Second: I went into SharePoint Central Admin > Security > General Security > Define blocked file types > removed .msi as a blocked extension.

The file now uploads and links correctly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.