I have a document library set to Classic experience and to open in the client application however it only opens documents in the online versions of the applications.

I have also enabled "Open Documents in Client Applications by Default" in the Site collection features and tried switching it from "Open in the client application" to "Use the server default (Open in the client application)" but this hasn't changed anything.

When I switch to the Modern experience all files open in their client applications as I would expect with the option enabled.

Does anyone know why this is happening or how to fix it? I am using Chrome as my browser.

  • We have just noticed the same issue. It seems that this setting is only respected in IE browser Jun 26, 2020 at 15:44

1 Answer 1


Per my test in my SharePoint online environment, the document can be opened in client application in new experience and classic experience.

To troubleshoot the issue, check things below:

  1. Add the site into trusted site in IE.

  2. Switch to other browser and check the result.

  3. Create a new document library to check if the same issue will occur.

  4. Switch to new experience and switch back to classic experience, then check if the document can be opened in client application.

More reference: Fix problems opening documents in SharePoint libraries.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.