1

We are facing an issue when we resolve people picker using the "Check Names" icon.

In SharePoint 2013: it shows the screen below:

When I type a user name (not login id) in the people picker text box, if that user is not resolved automatically, when I go to click over "Check Names" ico, it suggests me matching user name suffixing [Active Directory], for example Ankur Pial [Active Directory]. When I select the name from auto suggest list, it puts the name Ankur Pial [Active Directory].

That's annoying. In the below screen I have shown that.

enter image description here

SharePoint Online: Almost same thing happens, but it shows [Tenant] as a suffix. Something like this:

enter image description here

I want to know why this happens and how I can get rid of this? I don't want to show my end users [Active Directory] or [Tenant] thing, they don't understand these!

Advance help is appreciated!

  • This looks like SharePoint 2010 PeoplePicker. Where do you use it? A Form? Do you experience the same issue on a Site with SharePoint 2013 PeoplePicker? – MHeld Oct 27 '17 at 14:30
  • Yes it's a custom new form for list. The first scenario is for SharePoint 2013, the second one is SharePoint online. – Shahidul Haque Oct 27 '17 at 18:57
  • Do you experience the same issue on a Site with SharePoint 2013 PeoplePicker? – MHeld Oct 30 '17 at 6:35
  • Yes, for SharePoint 2013 it shows [Active Directory] suffixes with User Name. – Shahidul Haque Oct 31 '17 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.