5

Recently I was trying to Update Patch(update for SharePoint Server 2016 (KB4011053)). But when I tried to run PSConfig.exe,

Upgrade failed because of Missing Feature 'CustomTiles' (Id: 15/'68642d38-a556-4384-888c-082844fbf224') in WebApplication Database.

How can I install this feature in content database or can I remove this feature from SharePoint Farm?

Please suggest.

7

You can remove this feature from the farm, by doing the following:

enter image description here

  • Then click yes to remove Faulty Features in your farm

Another solution,

  • Try to run Test-SPContentDatabase as the following:

Test-SPContentDatabase

$wa = Get-SPWebApplication https://sharepoint.contoso.com"
$outputPath = "C:\\tools\files\Output\Test_Wss_Content_MissingAssembly_{0}.txt" -f (Get-Date -Format hhmmss
$dbName = "WSS_Content"
$slqServer = "SPSQL"
Test-SPContentDatabase -Name $dbName -WebApplication $wa -ServerInstance $slqServer -ShowLocation:$true -ExtendedCheck:$false | Out-File $outputPath Write-Host "Test results written to $outputPath"
  • Then open the file in the specified path, get the feature ID and Site ID in the location row and update the below script with theses entries.

  • Then run the below script to remove features by ID:

Script

$featureID = "Feature ID"
$siteID = "Site ID"   

#Display site information
$site = Get-SPSite $siteID  
Write-Host "Checking Site:" $site.Url

#Remove the feature from all subsites
ForEach ($web in $Site.AllWebs)
    {
        If($web.Features[$featureID])
            {
                Write-Host "`nFound Feature $featureID in web:"$Web.Url"`nRemoving feature"
                $web.Features.Remove($featureID, $true)
            }
            else
            {
                Write-Host "`nDid not find feature $featureID in web:" $Web.Url
            }  
    }

#Remove the feature from the site collection
If ($Site.Features[$featureID])
    {
        Write-Host "`nFound feature $featureID in site:"$site.Url"`nRemoving Feature"
        $site.Features.Remove($featureID, $true)
    }
    else
    {
        Write-Host "Did not find feature $featureID in site:" $site.Url
    }
  • Finally, run the below script

     Remove-SPFeatureFromContentDB -ContentDB "Wss_Content" -FeatureId "68642d38-a556-4384-888c-082844fbf224" –ReportOnly
    

If the above steps failed, so you would install the missing feature manually via Install-SPFeature

For more details check

  • Thanks M.Qassas, This what actually I got an error. "10/25/2017 06:55:45.11 OWSTIMER (0x1438) 0x1398 SharePoint Foundation Upgrade SPFeatureDefinition aj2bj ERROR Feature upgrade action 'CustomUpgradeAction.AddSwitchField' threw an exception upgrading Feature 'CustomTiles' (Id: 15/'68642d38-a556-4384-888c-082844fbf224') in WebApplication 'Portal Home': List |0 at |1 could not be found. 9355269e-2661-c0e9-3cf1-8977c126a8cd" – Srinu Dasari Oct 25 '17 at 12:55
  • Bro which solution you have tried? – Mohamed El-Qassas MVP Oct 25 '17 at 13:14
  • I have not yet tried – Srinu Dasari Oct 25 '17 at 13:45
  • Why? Do you have any issue to try the above solutions? please don't hesitate to tell us? – Mohamed El-Qassas MVP Oct 25 '17 at 13:46
  • When I ran that tool, i didnt find Feature with the name 'CustomTiles' . – Srinu Dasari Oct 25 '17 at 13:52
1

We had the same problem here. CustomTiles is a standard SharePoint Feature. It's neither missing nor faulty. It seems that the feature upgrade code has a bug though. The upgrade doesn't work if the hidden CustomTiles lists have never been created. These lists get created when you enable the feature. So what you have to do is enabling the CustomTiles feature on every web application in your farm.
You can do so using Powershell: Enable-SPFeature -Identity CustomTiles -Url UrlOfYourWebApplication -Force
After enabling the feature (which creates the hidden list) the upgrade worked for us without any errors.
If you want to know more about CustomTiles before enabling the feature see this TechNet article: https://technet.microsoft.com/en-us/library/mt790697(v=office.16).aspx
HTH
Christian

1

@Christian, to enable the Feature also worked in our Environment, I don´t know whats the case, but it worked. Also Folks, be Aware that I could be that you have to manually start w3svc Service during the wizard is working though the tokenservice might not be available for the upgrade process.!

Greetings Andre

0

enter image description here

Should I take any backup of this site or web application before I remove Faulty features? Why I as asking is there are Activation are there in site/farm lever.

  • I got same issue with some custom feature, I did not find this feature neither in FeatureAdminTool nor with PowerShell. Only I find this in AllList table in Content database.Even I did not find in Features Table in Content Database – Srinu Dasari Jun 19 at 10:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.