1

I have main SharePoint site on domain contoso.com and app is on contosoapps.com

I created all the required entries in DNS. like Host A and CNAME for wildcard.

Now both are working fine but when i open the app, it asking for credentials.

Is there any way we can skip that popup of credentials?

1

Based on your comments, i see three solutions:

  1. Users have to add your AppDomain to the InternetExplorer Zone "Local Intranet" on the client manually.

IE Zones

  1. Implement ADFS + WebApplicationProxy with Kerberos-Authentication on Windows Server 2016. If configured correctly, WAP will use User's SharePoint authentication and pass it through to your AppDomain.

  2. Instead of OnPremises WAP you can publish SharePoint via Azure AD ApplicationProxy. It's super-easy to implement, but you need an Azure AD Basic License for each user.

  • how we do in client machine? is there any proper solution? @Mheld – Rahul Oct 25 '17 at 8:51
  • This is normally deployed to the whole organization with Group Policies. There are two ways to build an according GPO, both are described here: blog.thesysadmins.co.uk/…. I highly prefer the second way, as it doesn't break existing settings and still allows users to add sites on their own. – MHeld Oct 25 '17 at 9:08
  • For testing you can add the site on one client manually as you can see in my screenshot. – MHeld Oct 25 '17 at 9:09
  • Yes, your answer is correct but our site users are not in our domain. – Rahul Oct 25 '17 at 9:22
  • Updated answer above – MHeld Oct 25 '17 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.