2

Is there a way to only allow certain file extensions to be attached? I recently added an attachment download button in the body of an automatic email, but it only works for one attachment name or a zip file, so I want to force all attachments to be of the '.zip' extension. Is this possible via SharePoint Designer or InfoPath Designer?

1

As you had known, if you are designing a browser-compatible form template, you won't be able to specify which file types are allowed in the file attachment control.

In other words, if you create an InfoPath form using Blank Form (InfoPath Fillter) template, you will have that checkbox.

enter image description here

If you’re using InfoPath browser forms, then this option is not available and you’ll have to programmatically restrict file types for InfoPath attachments.

0

You can create an infopath form and use a FileAttachment control.

  1. Double-click the file attachment control.
  2. Click the Data tab.
  3. Under Validation and Rules, select the Allow the user to attach only the following file types check box, and then, in the box, type the file extensions for the file types that you want to allow.
  • Thanks for answering Amal. I'm not sure if I'm doing something wrong, but when I double click on the attachment control and try to go to the data tab, everything is greyed out. Any idea why this would be? – Jake H. Oct 23 '17 at 18:40
  • Is the form browser enabled? – Amal Hashim Oct 23 '17 at 18:41
  • I'm sorry, I'm a newbie at this. Where can I verify that it is enabled? – Jake H. Oct 23 '17 at 18:44
0

If I am understanding right, the real issue is files do not download correctly in your automatic emails. I will attempt to address the underlying issue and see if that helps you.

To force a file to download, use the following for the link:

https://[sitecollection].sharepoint.com/[siteurl]/_layouts/download.aspx?SourceUrl=[fileurl]

Replace the items in [ ], and use the full URL in [fileurl] and that should fix your underlying issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.