0

We are using Standard edition of sharepoint. In infopath form we are receiving the following error.(The amount of data that was returned by a data connection has exceeded the maximum limit that was configured by the server)

enter image description here

If SharePoint is enterprise edition in Central Admin--->General Application Settings--->Configure Info path Forms Services if we are changing the Data Connection Response Size this error will go.

But Standard edition this option is not there in Central admin.How to resolve this issue?

2

First, You should be aware of the InfoPath Forms service is only supported in SharePoint Enterprise Edition.

So you can't find the same Infopath setting in Central Administration For SharePoint Standard.

Note: Only the Workflow InfoPath Forms is supported in SharePoint Standard!

Second, regarding your error The Default data connection response size is 1500kb, If the response size from the data connection exceeds the default limit you will get this error

"The amount of data that was returned by a data connection has exceeded the maximum limit that was configured by the server administrator."

It looks like you have customized the Workflow InfoPath form to pull a lot of data, and in this case, you should remove the unnecessary fields to pull less data!

| improve this answer | |
  • its possible to change Default data connection response size in Infopath Designer – elina Oct 18 '17 at 6:11
  • Unfortunately, there is no setting in InfoPath Designer related to data connection response size, it should be server set not form set! – Mohamed El-Qassas MVP Oct 18 '17 at 6:39
  • there is any other way to resolve this issue ? – elina Oct 18 '17 at 6:49
  • Based on my humble knowledge, the available solution for SharePoint standard is what I have mentioned in the above answer! or upgrade your license to SharePoint EnterPrise Edition! – Mohamed El-Qassas MVP Oct 18 '17 at 6:55
  • can you confirm me this error will come based on task list item count or workflow history count ? – elina Oct 18 '17 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.