My workflow is sending emails to users when a document changed. But last day i added new document and edited it. I created new workflow section I Saved and Published. Everything looks fine but suddenly my workflow is not changed. When i open the sharepoint Designer i saw the last changes but when i start the workflow it is not sending emails.So , what is the problem ?

  • Did you save AND publish the workflow? 2 steps. Oct 17 '17 at 7:56
  • Yes many times. I can see my last release in workflow history.
    – f_gulay
    Oct 17 '17 at 8:07

This happens most of the time due to the caching mechanism in SharePoint Designer. What you need to do is the following:

  1. Close your SharePoint Designer
  2. Navigate to the following directory: %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache
  3. Delete everything in this directory
  4. Navigate to the following directory: %APPDATA%\Microsoft\Web Server Extensions\Cache
  5. Delete everything in this directory
  6. Open SharePoint Designer and try to publish your workflow again. Everything should now work.

For SharePoint Designer 2013 you need to do the following steps:

  1. Go to File > Options > General > Application Options
  2. In the General tab, under the General header, check if the "Cache site data across SharePoint Designer sessions” is ticked. If it is, unchecked it.
  3. Open your SharePoint Designer again and try to publish your workflows.
  • It's amazing solution. Thank you. I think it will work. But i don't want to delete cache. Can you tell me another way to save the cache?
    – f_gulay
    Oct 17 '17 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.