0

I'm trying to build a CamlQuery that returns all documents in my /public/ folder but I keep getting the same error. Am I formatting the query incorrectly?

{"One or more field types are not installed properly. Go to the list settings page to delete these fields."}    System.ApplicationException {Microsoft.SharePoint.SPException}

This is the query where meta="Test"

"<View><Query><Where><Contains><FieldRef Name=”Key_x0020_Topics”/><Value Type='SPFieldLookupMulti'>" + meta + "</Value></Contains></Where></Query></View>"; 

This is the HTML from the form which is using the "Key Topics" item but I don't believe I am formatting it correctly/

<tr>
        <td nowrap="true" valign="top" width="165px" class="ms-formlabel"><h3 class="ms-standardheader"><a name="SPBookmark_Key_x0020_Topics"></a>Key Topics</h3></td>
        <td valign="top" class="ms-formbody" width="450px" id="SPFieldLookupMulti">
        <!-- FieldName="Key Topics"
             FieldInternalName="Key_x0020_Topics"
             FieldType="SPFieldLookupMulti"
          -->
            <a href="/Lists/Key%20Topics/DispForm.aspx?ID=6&RootFolder=*">Test</a>

        </td>
    </tr>
2

Please try with following

"<View><Query><Where><Contains><FieldRef Name='Key_x0020_Topics'/><Value Type='SPFieldLookupMulti'>" + meta + "</Value></Contains></Where></Query></View>";

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.