I have scaffold-ed an spfx webppart project. But I am getting the following errors on compilation:

-> Cannot find module 'ToDoWebPartStrings'

-> Cannot find module './ToDo.module.scss'

-> Accessors are only available when targeting ECMAScript 5 and higher

-> I tried creating an spfx webpart using Angular js. I followed this blog Build SharePoint Framework client-side web parts with AngularJS

Below is a screenshot from the blog:

enter image description here

Even in the blog, an error is visible which the author has discarded unfortunately. Any help?

2 Answers 2


For anyone who got stuck here,do not get frustrated. Just use this keyword "gulp serve" in the command prompt. Once the workbench is run, the errors go away automatically. This worked at least in my case.

  • Indeed, this seems to be the VS code editor not finding the reference, but it will be resolved at compile time (gulp bundle / gulp serve). If not, double check the value of the path. Jul 10, 2019 at 12:29

If you are using VS Code you can install "SPFx Essentials". Fixed the errors for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.