This one bugs me since years, and I'm guessing it may not be solvable:

When clicking the link to a document (let's say a DOC file) inside Internet Explorer on a SharePoint 2010 website, Internet Explorer somehow instructs Office to start up and load the document via WebDAV (I guess it is WebDAV).

In contrast, if I do the same in any non-IE browser (i.e. Google Chrome, Mozilla Firefox, Apple Safari or Opera), the click on the link to a document simply downloads the file instead of passing the URL on to the office application.

My question is:

Is it possible to configure the server or the browser (both server-side solutions or client-side solutions are suitable in our environment) to not download a copy of a document but instead pass the request to the appropriate application?

Update August 2015:

Since Windows 10 and Microsoft Edge browser is now officially released, I tried to open SharePoint documents from within Edge.

And it works! The document actually gets openend in Office and not getting downloaded.

Since from my understanding, Edge does not suport ActiveX there has to be some kind of other mechanism going on here.

Update May 2016:

I've just discovered that when clicking an Excel oder Word link from within Google Chrome (I'm using version 52 of Chrome), a popup occurs and asks whether to open the file in Excel (or Word). So it is not trying to download the file.

It seems that there are now URI scheme handlers for these file types on my system.

I'm using Windows 10 with Office 2016 and SharePoint 2013.

I honestly don't know whether it is Google Chrome, Windows 10, Office 2016 or even SharePoint 2013 itself that is responsible for registering these URI scheme handlers.

But anyway I'm really happy!

(It probably will work for other Office documents like e.g. PowerPoint, too).

It will also work on Firefox, once I enabled the execution of Microsoft Office within Firefox.


2 Answers 2


If you examine the link to the document with IE developer tools you'll see that it is a hyperlink and a JavaScript function attached to the onClick event.

The JavaScript function checks if ActiveX is supported in the client Web browser and if a particular client-side ActiveX component (IIRC something with "OpenDocuments") is available. This client-side ActiveX component is installed with Word/Excel/PowerPoint etc.

Since Internet Explorer is the only Web browser on the market which supports ActiveX Word/SharePoint is using it in this case.

For all other Web browsers the JavaScript function returns false and let the browser open a download dialog.

So, a simple configuration option to make all browsers behave the same way is not available.

Instead it would require some Windows client-side and SharePoint server-side development to implement a similar feature for non-IE users. Not impossible, but quite a bit of work.

Another option might be to deploy Office Web Apps if you have the appropriate Microsoft license for SharePoint Server 2010 and are a volume license customer.

Update: there appears to be a Mozilla Firefox Plugin in Office 2010 (see http://msdn.microsoft.com/en-us/library/ff407576.aspx) but I haven't tried it myself.

  • 1
    For a detailed overview of what's supported and what's not, see technet.microsoft.com/en-us/library/cc263526.aspx
    – molgar
    Nov 6, 2011 at 17:53
  • For those reading this accepted answer, see the updates in the description from the author in 2015 & 2016. Sounds like latest combination of Win10 plus latest Office 2016 plus latest SharePoint 2013 may have things working. FYI, I can confirm that SharePoint Online plus Office365 plus Win10 plus Firefox 62, everything working well.
    – netjeff
    Oct 3, 2018 at 20:47


npOpenDocuments (formerly WSSFirefox) implements SharePoint & Office integration for non-IE browsers. Now Firefox & Google Chrome browsers can open MS Office documents directly, without saving them into temporary folder first. Check-in, Check-out & co are also supported.

This works for Office 2007/2010 & SharePoint 2007/2010

  • "This project is no longer supported". Seems not a good thing to go with.
    – Uwe Keim
    Mar 18, 2014 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.