2

When I run the following commands to create a sharepoint framework solution, change directory to the new solution and then add a second web part to the solution...

yo @microsoft/sharepoint --solutionName "intranet" --framework "react" --componentType "webpart" --componentName "myteam" --componentDescription "My Team Members" --environment "onprem" skipFeatureDeployment true cd intranet yo @microsoft/sharepoint --componentType "webpart" --componentName "test1" --framework "react" --componentDescription "test1234" --skip-install

...the result is an error "cannot read property 'foreach' of undefined":

cannot read property foreach of undefined

My Yeoman package version is 1.3.2: { "@microsoft/generator-sharepoint": { "version": "1.3.2", ...

I get the same result regardless of generating a react or knockout project. Any ideas?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.