I have a subsite where I have owner permissions: I can create and run workflows, can create new forms, but I cannot modify them! Even the just created forms appear highlighted in yellow and "advanced mode" icon disabled.

enter image description here

I can guess there is a problem with permissions, but unfortunately, I have no access (with owner permission) at site collection level. I have been checking on any list and/or library in the site and always have the same issue. In other sites I can do anything with forms - so it is not a SPD issue.
Some idea where to check?


1 Answer 1


could be several issues. Make sure that your account has custom scripts enabled.

next phase would be to make sure that you are using the correct account to edit the forms. Logout from sharepoint using Internet explorer and then navigate to your site from SPD.

You could also check on SPD what account is currently running. click on file -> account

issue is either your using wrong account or the account or site that you are using doesn't have the correct privileges to edit the forms in SPD and you can check if it does have this enabled for the site by going to "/_layouts/SharePointDesignerSettings.aspx"

More detailed explanation here from Microsoft:

Manage Permissions and Control Access to Sharepoint Designer

  • Thanks, I'll go step by step basing on MS page you linked. I don't know what happens when SPD is not enabled at site collection level... I see I can created and run workflows, so I thought it is not the case.
    – Marpio
    Oct 9, 2017 at 9:30
  • did you go to /_layouts/SharePointDesignerSettings.aspx to check what is enabled for sharepoint designer?
    – Ali Jafer
    Oct 9, 2017 at 9:46
  • I have no access there... trying to get it, but it means something...
    – Marpio
    Oct 9, 2017 at 11:51
  • sorry that was for sharepoint online. You need to do this on the server in central admin, follow this guide redmondmag.com/articles/2015/03/19/…
    – Ali Jafer
    Oct 9, 2017 at 12:35
  • I am on Sharepoint online, your suggestion is right, but I am afraid the settings of the SC are bad, just I cannot see them...
    – Marpio
    Oct 9, 2017 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.